Author Topic: Connecting 802.11g WLAN access point  (Read 5762 times)

0 Members and 1 Guest are viewing this topic.

Offline kirmou

  • Newbie
  • *
  • Posts: 13
    • View Profile
  • Phone model: Jolla
Connecting 802.11g WLAN access point
« on: December 12, 2013, 11:19:19 AM »
A minor issue I noticed is that connecting to a WPA2 protected 802.11g WLAN access point (I use Linksys WRT54G v.7) seems not to work. I get the error Connecting to the chosen network did not succeed type of error.  The WPA password is not even asked.  Has anyone else succeeded in this?

Connecting to 802.11n WLANs works fine.

Offline qrosh

  • Newbie
  • *
  • Posts: 2
    • View Profile
  • Phone model: Jolla
Re: Connecting 802.11g WLAN access point
« Reply #1 on: December 15, 2013, 04:28:31 PM »
Do you use a security certificate for your network?
Because as far as I have experienced 802.X networks do not work.
I do not have any issues with 802.11g wifi.

Offline kirmou

  • Newbie
  • *
  • Posts: 13
    • View Profile
  • Phone model: Jolla
Re: Connecting 802.11g WLAN access point
« Reply #2 on: December 17, 2013, 07:00:50 AM »

What do you mean by security certificate?
I use WPA2 personal password protected security settings in the Linksys WRT54G APN.

Another test in which the Jolla failed was connecting to Android portable Wi-Fi hotspot (802.11g with WPA2 password protection).

Offline xiaohuihui.z

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Connecting 802.11g WLAN access point
« Reply #3 on: December 17, 2013, 11:52:07 AM »
I can't connect to the wifi below

security type : WPA2-Entreprise
encryption type:AES
a method of network authentication:Microsoft:PEAP(Protected EAP)
802.1X EAP


Offline qrosh

  • Newbie
  • *
  • Posts: 2
    • View Profile
  • Phone model: Jolla
Re: Connecting 802.11g WLAN access point
« Reply #4 on: December 17, 2013, 04:35:05 PM »
802.1X is not possible yet. But should be possible with console. I did not try it yet, but in theory it should!
                            ^
I meant the above by 'with certificate'.

Offline breiti_oi

  • Newbie
  • *
  • Posts: 17
    • View Profile
  • Phone model: N900 -> N9 -> Jolla Phone
Re: Connecting 802.11g WLAN access point
« Reply #5 on: December 21, 2013, 08:08:36 PM »
has someone managed to connect to an hidden network?

Offline kirmou

  • Newbie
  • *
  • Posts: 13
    • View Profile
  • Phone model: Jolla
Re: Connecting 802.11g WLAN access point
« Reply #6 on: December 23, 2013, 11:43:29 AM »

What do you mean by security certificate?
I use WPA2 personal password protected security settings in the WRT54G APN.

Another test in which the Jolla failed was connecting to Android portable Wi-Fi hotspot (802.11g with WPA2 password protection).

After Sailfish 1.0.1.12 update I have had no problems connecting to the  Linksys WRT54G with WPA2 personal security.  Also connecting to the Android portable Wi-Fi hotspot (802.11g with WPA2 password protection) seems to work.
:)


Offline Igor80

  • Newbie
  • *
  • Posts: 9
    • View Profile
  • Phone model: Jolla
Re: Connecting 802.11g WLAN access point
« Reply #7 on: December 23, 2013, 02:09:54 PM »
I have the same problem. Phone does not connect to my router Asus RT-N66U if WPA or WPA2 activated. It connects if I set open WiFi.
My old N9 connects without problem with any Authentication Methods.
6310i->E61->E71->N900->N9->Jolla

Offline jimbim

  • Newbie
  • *
  • Posts: 1
    • View Profile
  • Phone model: jolla
Re: Connecting 802.11g WLAN access point
« Reply #8 on: December 24, 2013, 10:47:06 AM »
I have a similar issue, but my sailfish os beta's version is up to date (Sailfish 1.0.1.12).  :-[
I've tried to connect different networks (different routers and different ssecurity), and it seems that its works only with the unsecured open network.
But before I downloaded the update i could connect to my workplace's wifi (WPA2-PSK secured)
Now when i'm clicking to a password protected network for connecting, it prints immediately the sorry error message, and dont asking for the password...
Am I doing something wrong?  >:(
« Last Edit: December 24, 2013, 10:53:10 AM by jimbim »

Offline zool

  • Newbie
  • *
  • Posts: 18
    • View Profile
  • Phone model: Jolla
Re: Connecting 802.11g WLAN access point
« Reply #9 on: December 25, 2013, 08:40:16 AM »
has someone managed to connect to an hidden network?
I managed to connect to my hidden network, I used the developer mode, because I have static IPs, put I do not use a Passphrase. I did not managed to connect to a hidden WPA2 network, after trying 3 times the WiFi settings hang up and only came back after a reboot of the phone.

Offline breiti_oi

  • Newbie
  • *
  • Posts: 17
    • View Profile
  • Phone model: N900 -> N9 -> Jolla Phone
Re: Connecting 802.11g WLAN access point
« Reply #10 on: December 25, 2013, 12:09:24 PM »
 :o hidden network seem's to work also here right now, only the network icon don't change sometimes from mobile network to WLAN.
i only had to set the network visible for the time i needed to configure and change it back afterwards.
now it also works with WPA2.
« Last Edit: December 25, 2013, 12:13:21 PM by breiti_oi »